• Advertisement

Is our new Pot still working correctly?

These are simple stills with no column. Doublers and puke boxes are allowed.

Is our new Pot still working correctly?

Postby Boomtown » Thu Dec 31, 2015 4:09 pm

This is my 4th cycle with our new 55 Gallon Still form Affordable Distillery Equipment LLC. I'm surprised at how it's working and am wondering if I'm doing this right.

The pot has 2 electric heating elements that bring the temperature up rapidly, I back the power off when the pot's temp gauage says 190F. The head is 24" x 4" Copper, and discharges through a 1/2" opening into a 4' liebreg. The Temp gauge at the top of the column always reads at 200 F while it is producing. That's what I find odd. Why is the top of the column hotter than the body of the still?

This new still output runs at 30% ABV, and 78F , which seems to me to be very warm output and very low ABV. In the past, using some gear I made at home, I've been able to get 60% ABV with our 100L SS pot, which is set up very similarly but only one electric heating element.

I was expecting this still to produce above 50% ABV. Any suggestions, or comments? What can I do differently to improve the ABV output?
Boomtown
 
Posts: 56
Joined: Tue May 07, 2013 1:45 pm

Re: Is our new Pot still working correctly?

Postby punkin » Thu Dec 31, 2015 4:46 pm

I wouldn't be taking any notice of any of those temperatures on a pot still if it was me.
ABV output is a direct relation to wash ABV, unless you are leaking vapour the abv should be the same with the same wash give or take.

Isn't the manufacturer providing you with support?
Image

Identified Shit Stirrer, upgraded to sociopath.

To the fashionable nationalists



http://www.stilldragon.com.au for all your distilling needs in Australia and New Zealand
User avatar
punkin
 
Posts: 11363
Joined: Sun Dec 16, 2007 2:09 pm
Location: Northern NSW Orstrailya

Re: Is our new Pot still working correctly?

Postby Boomtown » Fri Jan 01, 2016 9:41 am

I'm waiting on a response yet, no answer from the manufacturer to an email .... Mom always said if you cant say something good about someone, say nothing.
Boomtown
 
Posts: 56
Joined: Tue May 07, 2013 1:45 pm

Re: Is our new Pot still working correctly?

Postby punkin » Fri Jan 01, 2016 12:20 pm

Like i said if there was no vapour leak i'd be looking at your wash. Are you dooing all grain corn by chance? If so try a sugar wash like UJSSM and see how the still goes on that. It would make a good learning run and prove one way or another.
Image

Identified Shit Stirrer, upgraded to sociopath.

To the fashionable nationalists



http://www.stilldragon.com.au for all your distilling needs in Australia and New Zealand
User avatar
punkin
 
Posts: 11363
Joined: Sun Dec 16, 2007 2:09 pm
Location: Northern NSW Orstrailya

Re: Is our new Pot still working correctly?

Postby Boomtown » Fri Jan 01, 2016 7:25 pm

[quote="punkin"]Like i said if there was no vapour leak i'd be looking at your wash. Are you dooing all grain corn by chance? If so try a sugar wash like UJSSM and see how the still goes on that. It would make a good learning run and prove one way or another

Yeah we've been doing an all grain wash for months, in a different still. This process is a step up in volume, both of the still and the wash. I like that idea of a sugar wash, it will take a week to work it up, but it will prove the process...thanks.

Boom
Boomtown
 
Posts: 56
Joined: Tue May 07, 2013 1:45 pm


Return to Pot Stills

Who is online

Users browsing this forum: No registered users and 4 guests